..

Δευτέρα, 6 Φεβρουαρίου 2017

Μετά από μεγάλο χρονικό διάστημα επιτέλους η τελική έκδοση του cydia 1.1.28 έχει ολοκληρωθεί και είναι διαθέσιμη για όλους στο επίσημο ρεπό.

Σύμφωνα με τον δημιουργό του ο νέος Cydia περιλαμβάνει πολλές αλλαγές στην δομή του και τώρα δεν εμφανίζει τα γνωστά σφάλματα αφού άλλαξε η διαχείριση των πακέτων που χρησιμοποιείται.
Υποστηρίζονται τώρα χωρίς προβλήματα όλες οι συσκευές 64bit και φυσικά προσαρμόστηκε και για το ios 10 χωρίς όμως να σταματήσει η υποστήριξη παλιότερων jailbreak από το ios 8,4 και μετά.
Τέλος διορθώθηκε το πρόβλημα των SSH στο ios 10 με το   Yalu και επιτέλους άνοιξαν επίσημα και οι αγορές όπου μπορείτε πλέον να δείτε τα αγορασμένα σας πακέτα και να τα ξανά κατεβάσετε η να κάνετε νέες αγορές.
Μαζί με το cydia θα βρείτε άλλα δυο πακέτα εξαρτήσεις που είναι το Tape Archive και το Debian Packager.
Πραγματοποιήστε την αναβάθμιση μόλις αυτή εμφανιστεί στην συσκευή σας και προσοχή μην διακόψετε την διαδικασία μέχρι να ολοκληρωθεί.



Changes in Cydia 1.1.28

Cydia now uses APT 1.14~b
This is a major update to the core package management logic used by Cydia. This library, which is shared with Linux distributions such as Debian and Ubuntu, is an industry standard, which Cydia has been excited to share. For purposes of performance and reliability, Cydia had a number of patches to the (rather old) copy of APT it had been using. It turns out APT's upstream has been paying attention, and was excited to have us update.
The big thing to know about this change is that there are a handful of repositories that are simply broken, and older versions of Cydia failed to notice. We've had this build of Cydia in a "public beta" now for an entire month, which has been a lot of time to get the more important of these to fix their corrupt metadata files. However, you may still run into warnings: you should remove the repositories which are broken, and it is not a bug in Cydia that you see warnings.
Cydia is now a 64-bit Process
Cydia is now compiled for ARM64. While this offers Cydia very little direct advantages (and probably comes at a performance penalty), this avoids a misleading dialog box from Apple and also happened to work around an iss on iOS 10 where no links in Cydia could be clicked. Note that this means that any extensions installed to modify Cydia will now need to be recompiled for 64-bit as well.
Support for iOS 10
There are at least a handful of users using iOS 10 due to the new Yalu jailbreak: this version of Cydia has a couple minor modifications to make this work better for them. For those worried about Cydia on older systems: the vast majority of users are using iOS 7, 8, and 9 (in nearly equal percentages), and Cydia continues to support even older versions of iOS, so do not feel concerned about updating (I still haven't updated from my iOS 8.4 primary phone ;P).
Some Random Bug Fixes
iAdam1n reported an issue where removing a repository could cause Cydia to not provide a UI to return to the previous screen. Find Extensions for Applications was broken for a few releases, but has now been fixed. Due to the new Yalu jailbreak shipping with SSH, some long-standing "right after jailbreak" bugs were able to be understood and fixed, making Cydia less likely to fail right after installation.
Add a Comment

6 σχόλια :

  1. Γιώργο καλησπέρα!μετα την αναβάθμιση του cydia αντιμετωπίζω το εξής πρόβλημα...στην έναρξη του cydia γράφει επάνω στο κέντρο "βάση δεδομένων 0%" απο κάτω με κίτρινα γράμματα "unable to parce package file και τις διευθύνσεις στο var διαφόρων sources με την κατάληξη release" πατώντας λοιπόν το επιστροφή στο cydia που γράφει κάτω και επιχειρώντας να κάνω είτε αναβάθμιση είτε εγκατάσταση κάποιου Καινούργιου tweak μου crashάρει ο cydia δοκίμασα καθαρισμ με I cleaner το άφησα πεντάλεπτο κλειστό αλλα εξακολουθεί το ίδιο...6s 64 gb iOS 9.1 τι κάνουμε;;🤔

    ΑπάντησηΔιαγραφή
  2. Αν δεν βγάζεις άκρη με το cydia που πιστεύω πρέπει να σβήσεις κάποια ρεπό που δεν λειτουργούν, μπορείς να το βάλεις χειροκίνητα αν έχεις το ifile http://apt.saurik.com//debs/cydia_1.1.28_iphoneos-arm.deb

    ΑπάντησηΔιαγραφή
  3. Δυστυχώς Γιώργο έκανα ότι μου πρότεινες μα και πάλι τίποτα όταν ανοίγω τον cydia γράφει "encountered a section with no package header" και όταν προσπαθώ να Εγκαταστήσω ή να αναβαθμισω κάποιο tweak τοτε crashάρει ο cydia!ο μόνος τρόπος που δοκίμασα και κατάφερα να εγκατέστησε tweak ήταν να ανοίξω το μήλο με πατημένο το +volume(απενεργοποιώντας έτσι ολα τα tweaks)για ποιον λόγο όμως συμβαίνει αυτό εφόσον δεν είχα εγκαταστήσει η αναβαθμίσει κάποιο tweak πριν μου το παρουσιάσει αυτό;🤔Ειναι δυνατόν να μην ειναι συμβατό κάποιο προηγούμενο tweak με την νέα έκδοση του cydia στην οποία έκανα την αναβάθμιση;έχεις καμία σκέψη-λύση;

    ΑπάντησηΔιαγραφή
  4. ναι είναι δυνατόν ένα tweak να μην είναι συμβατό και σου κολλάει μέχρι και όλη την συσκευή ένα ένα πάντα και θα είσαι σίγουρος αν είναι συμβατό

    ΑπάντησηΔιαγραφή
  5. Να επιστρέψω στην προηγούμενη έκδοση του cydia γίνεται;το προτείνεις;

    ΑπάντησηΔιαγραφή
  6. Επέστρεψα στην 1-27 και έπαψε το πρόβλημα απλά αγνοώ το μήνυμα για update

    ΑπάντησηΔιαγραφή